【BZOJ1628】[Usaco2007 Demo]City skyline

描述 Description

The best part of the day for Farmer John’s cows is when the sun sets. They can see the skyline of the distant city. Bessie wonders how many buildings the city has. Write a program that assists the cows in calculating the minimum number of buildings in the city, given a profile of its skyline.

The city in profile is quite dull architecturally, featuring only box-shaped buildings. The skyline of a city on the horizon is somewhere between 1 and W units wide (1 <= W <= 1,000,000) and described using N (1 <= N <= 50,000) successive x and y coordinates (1 <= x <= W, 0 <= y <= 500,000), defining at what point the skyline changes to a certain height.

An example skyline could be:

……………………..

…..XX………XXX…….

.XXX.XX…….XXXXXXX…..

XXXXXXXXXX….XXXXXXXXXXXX

and would be encoded as (1,1), (2,2), (5,1), (6,3), (8,1), (11,0), (15,2), (17,3), (20,2), (22,1).

This skyline requires a minimum of 6 buildings to form; below is one possible set of six buildings whose could create the skyline above:

…………………….. ……………………..

…..22………333……. …..XX………XXX…….

.111.22…….XX333XX….. .XXX.XX…….5555555…..

X111X22XXX….XX333XXXXXXX 4444444444….5555555XXXXX

……………………..

…..XX………XXX…….

.XXX.XX…….XXXXXXX…..

XXXXXXXXXX….666666666666

输入格式 InputFormat

Line 1: Two space separated integers: N and W.

Lines 2..N+1: Two space separated integers, the x and y coordinate of a point where the skyline changes. The x coordinates are presented in strictly increasing order, and the first x coordinate will always be 1.

输出格式 OutputFormat

Line 1: The minimum number of buildings to create the described skyline.

样例输入 SampleInput

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1

样例输出 SampleOutput

6

来源 Source

Silver


BZOJ 1628

POJ 3044


代码 Code

维护一个单调递增栈。

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int f[1000005];
int i,j,t,n,m,l,r,k,z,y,x,ans;
int main()
{
    scanf("%d%d",&n,&m);
    ans=0;r=0;f[r]=0;
    for (i=1;i<=n;i++)
    {
         scanf("%d%d",&x,&y);
         while (f[r]>y)
         {
            ans++;
            r--;
         }
         if (f[r]==y) continue;
         f[++r]=y;
    }
    while (f[r]>0)
    {
        ans++;
        r--;
    }
    printf("%d\n",ans);
    return 0;
}