【BZOJ1629】[Usaco2007 Demo]Cow Acrobats

描述 Description

Farmer John’s N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. The cows aren’t terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves within this stack. Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

// 有三个头牛,下面三行二个数分别代表其体重及力量.

// 它们玩叠罗汉的游戏,每个牛的危险值等于它上面的牛的体重总和减去它的力量值,因为它要扛起上面所有的牛嘛.

// 求所有方案中危险值最大的最小

输入格式 InputFormat

Line 1: A single line with the integer N. * Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i.

输出格式 OutputFormat

Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

样例输入 SampleInput

10
10 10
3 3
1 1
2 2
9 9
7 7
4 4
5 5
6 6
8 8

样例输出 SampleOutput

35

来源 Source

Silver


BZOJ 1629


代码 Code

可证贪心。

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define inf 0x7fffffff/27.11
struct cow
{
    int w,s;
}a[50005];
int i,j,t,n,m,l,r,k,z,y,x,ans;
bool comp(cow a,cow b)
{
    return a.w+a.s<b.w+b.s;
}
int main()
{
    scanf("%d",&n);
    for (i=1;i<=n;i++) scanf("%d%d",&a[i].w,&a[i].s);
    sort(a+1,a+n+1,comp);
    ans=-inf;
    t=0;
    for (i=1;i<=n;i++)
    {
        ans=max(ans,t-a[i].s);
        t=t+a[i].w;
    }
    printf("%d\n",ans);
    return 0;
}