[BZOJ1635]&&[Usaco2007 Jan]Tallest Cow 最高的牛

描述 Description

FJ’s N (1 <= N <= 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 <= H <= 1,000,000) of the tallest cow along with the index I of that cow. FJ has made a list of R (0 <= R <= 10,000) lines of the form“cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17. For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

有 n(1 <= n <= 10000) 头牛从1到 n 线性排列,每头牛的高度为 hi, 现在告诉你这里面的牛的最大高度为 maxH, 而且有 r 组关系,每组关系输入两个数字,假设为 a 和 b, 表示第 a 头牛能看到第 b 头牛,能看到的条件是 a, b 之间的其它牛的高度都严格小于 min(h[a], h[b]), 而 h[b] >= h[a].

输入格式 InputFormat

Line 1: Four space-separated integers: N, I, H and R.

Lines 2..R+1: Two distinct space-separated integers A and B (1 <= A, B <= N), indicating that cow A can see cow B.

输出格式 OutputFormat

Lines 1..N: Line i contains the maximum possible height of cow i.

样例输入 SampleInput

8 1 7 6
1 2
3 4
2 4
7 6
6 8
5 8

样例输出 SampleOutput

7
7
6
7
7
6
5
7

来源 Source

Silver


BZOJ 1635


代码 Code

注意判重。

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
struct point
{
    int z,y,x;
}a[10005];
int ans[10005];
int i,j,t,n,m,l,r,k,h;
bool comp(point a,point b)
{
    if (a.x!=b.x) return a.x<b.x;
    else return a.y<b.y;
}
int main()
{
    memset(ans,0,sizeof(ans));
    scanf("%d%d%d%d",&n,&k,&h,&m);
    for (i=1;i<=m;i++)
    {
        scanf("%d%d",&a[i].x,&a[i].y);
        if (a[i].x>a[i].y) swap(a[i].x,a[i].y);
    }
    sort(a+1,a+m+1,comp);
    for (i=1;i<=m;i++)
    {
        if (a[i].x==a[i-1].x && a[i].y==a[i-1].y) continue;
        for (j=a[i].x+1;j<a[i].y;j++)
        {
            ans[j]--;
        }
    }
    for (i=1;i<=n;i++) printf("%d\n",h+ans[i]);
    return 0;
}