【cf433A】Kitahara Haruki's Gift

描述 Description

Kitahara Haruki has bought n apples for Touma Kazusa and Ogiso Setsuna. Now he wants to divide all the apples between the friends.

Each apple weights 100 grams or 200 grams. Of course Kitahara Haruki doesn’t want to offend any of his friend. Therefore the total weight of the apples given to Touma Kazusa must be equal to the total weight of the apples given to Ogiso Setsuna.

But unfortunately Kitahara Haruki doesn’t have a knife right now, so he cannot split any apple into some parts. Please, tell him: is it possible to divide all the apples in a fair way between his friends?

输入格式 InputFormat

The first line contains an integer n (1 ≤ n ≤ 100) — the number of apples. The second line contains n integers w1, w2, …, wn (wi = 100 or wi = 200), where wi is the weight of the i-th apple.

输出格式 OutputFormat

In a single line print “YES” (without the quotes) if it is possible to divide all the apples between his friends. Otherwise print “NO” (without the quotes).

样例输入 SampleInput

4
100 100 100 200

样例输出 SampleOutput

NO

数据范围和注释 Hint

In the first test sample Kitahara Haruki can give the first and the last apple to Ogiso Setsuna and the middle apple to Touma Kazusa.


Codeforces 433A


代码 Code

水。

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define inf 0x7fffffff
int a[101];
int i,j,t,n,m,l,r,k,z,y,x,tot,tot1,tot2;
int main()
{
    scanf("%d",&n);
    tot=0;
    for (i=1;i<=n;i++) 
    {
        scanf("%d",&a[i]);
        tot+=a[i];
        if (a[i]==100) tot1++;
        else tot2++;
    }
    tot2%=2;
    if (tot2)
    {
        if (tot1<2)
        {
            printf("NO");
            return 0;
        }
        else tot1-=2;
    }
    if (tot1%2!=0)
    {
        printf("NO");
        return 0;
    }
    printf("YES");
    return 0;
}